Investigating Intermittent Voice Audio Issues
Resolved
May 22, 2026 at 1:30pm UTC
We're observing vast improvements across the boards. If you are still experiencing issues with intermittent audio, please contact our Helpdesk and they will assist you further.
Affected services
Updated
May 20, 2026 at 2:37pm UTC
We have begun rolling out changes that we believe will have a positive impact on the experienced issue. We will continue to monitor and we encourage customers to reach out to us if you still experience intermittent audio issues such as cut audio, lag, or delays.
Affected services
Updated
May 19, 2026 at 3:55pm UTC
Additional troubleshooting tools has been deployed and released. Continue monitoring.
Affected services
Updated
May 19, 2026 at 12:35pm UTC
Additional logging are being implemented to better understand the cause of this issue, and is expected to be finished in the upcoming hours.
Affected services
Updated
May 19, 2026 at 7:01am UTC
We are currently in the process of analysing this issue, together with the additional logging implemented.
Affected services
Updated
May 18, 2026 at 6:46am UTC
We are continuing work on adding additional logging.
Affected services
Updated
May 13, 2026 at 2:08pm UTC
We’re enhancing logging in certain areas of the platform to help us better understand and identify the root cause of the issue.
Affected services
Created
May 13, 2026 at 1:03pm UTC
We’re currently investigating an issue impacting some agents’ ability to handle voice calls. In rare cases, audio may intermittently cut out during active calls on certain device or network setups.
Affected services